Can not update from 1.1.2 to 1.20

GenerateBlocks Pro adds more great features to GenerateBlocks without sacrificing usability or performance. Version 1.1.2

There is a new version of GenerateBlocks Pro available. [View version 1.2.0 details]Automatic update is unavailable for this plugin.

Can not update the plugin, we are paying customer. We added the website to the dashboard in generateblocks, still can not update to 1.20 with wordpress

Please help!

Hi @GlasulVietii,

Can you try removing and then re-adding your license key?

Here’s an article which may assist you: Updating Issues - Documentation

Lastly, if any steps in the article doesn’t work, can you try updating manually from Log In ‹ GenerateBlocks — WordPress

Kindly let us know how it goes.

Hi, I dont have this in wordpress

To re-authorize your license key, go to GenerateBlocks > Settings and click the Save button under your license key field.

There is no settings option to GenerateBlocks in Wordpress! Where do i find it?

Try Appearance >> GeneratePress from the WordPress menu on the left
And as mentioned, if it looks like your license key is active, remove it, save, then paste it back in, and save again - that usually fixes it!
HTH, Dave

1 Like

It should be in your admin dashboard as such: Settings ‹ fazarcon test — ...

To clarify, is this not appearing from you end?

@davep told be about Generatepress, but this is generateblocks
I did what @fernandoazarcon2 told me and found those settings, but when I remove the license key and click Save this shows up

So I remove the license , click Save, error shows up, I copy paste License , click Save , license ok , Still can not update to 1.2.0 , no dialog to update, still 1.1.2 (GenerateBlocks)

I see. Can you try manually updating, and check if you’ll be able to add the license key afterwards?: Updating Issues - Documentation

Kindly let us know.

Hi @GlasulVietii, sorry about that, but usually same logic applies.
The only other thing I can think of, is that some IP’s are blocked by providers and that may be why it is not working!
Good look, Dave

Put the 1.1.2 on another website. Dialog shows up to update. When i try to update to 1.2.0 this shows up:

License is ok in settings and add the website in generateblocks account dashboard

Something is very wrong here, just lost so much time debugging.

To clarify, did manually updating not work?

I have to manually update to 1.2.0 on every website that we have 1.1.2 installed. Now is 1.2.0.

If something go wrong we will update you. Thanks!

To clarify, manually update worked. There is something wrong with 1.1.2 version on Wordpress 5.9 and above, it doesnt do auto update.

Auto update not working again! There is 1.3.0 but no info to update to 1.3.0

Remove the lincense key, save, put it back, save, still no popup to update to 1.3.0

I have to manual update again to 1.3.0 that worked.

Please fix: no pop up to update to next version Generate Blocks Pro

It seems like something is wrong with the license key activation and your server.

Try adding this function to your site - it will use our secondary API for updates:

add_filter( 'pre_http_request', function( $pre, $args, $url ) {
    if ( 'https://generateblocks.com' === $url || 'https://generateblocks.com/' === $url ) {
        return wp_remote_post(
            'https://api.generateblocks.com',
                array(
                    'timeout' => $args['timeout'],
                    'sslverify' => $args['sslverify'],
                    'body' => $args['body'],
                )
        );
    }
	
    return $pre;
}, 10, 3 );

The request is cached, so it may take a couple of hours for the secondary API to take effect.