Bug with transform that's disabled in Editor

Steps to reproduce:

  1. While in the block editor, create a container with some content in it.
  2. Add a translateY Transform with -500 value (in my case).
  3. Toggle the Disable in editor toggle.
  4. Click out of the container that you just apply the transform.
  5. Container shifts position as if the Disable in editor toggle hadn’t been selected.
  6. Click back to the container.
  7. Container retains position again.

I was wondering if there was a quick fix before the next update since it’s quite difficult to work with and I am doing some critical work.

Thanks.

As of right now, the Disable in editor toggle only disables the effect if the block is selected.

For example, if you’re working on the block or a block inside of the block with the effect, the transform won’t apply.

However, when you de-select the block, it will apply so you can get a realistic idea of how your content looks/functions.

Does that sound like what you’re seeing?

Yeah, that’s what happens, Tom. So it’s expected behavior. Shouldn’t it be a way to have it disabled even when it is selected? So it won’t get in the way of designing your layout…

There’s certainly an argument to made there. My thinking was that if the block wasn’t selected, the effect shouldn’t get in the way (as you’re working on other blocks). However, I suppose that depends on the effects you’re building.

Perhaps it would make more sense to fully disable them if set - I would be open to that.

That would make sense since the toggle is there to enable/disable and it should actually do what it says, I guess!

1 Like